All the latest news and reviews are now available via the NZTechie.com homepage at https://www.nztechie.com

Wednesday, December 26, 2007

My Photo Gallery is Reborn!

After the recent problems with my photo gallery due to Startlogic disabling allow_url_fopen functionality, I decided to bite the bullet and have installed Gallery version 2.2. This version does not suffer the same limitations as version 1.5 which I had installed.

Installation was a breeze, with some fantastic instructions provided for full installation. After installation, I successfully imported all of my version 1.5 photo albums into 2.2. This worked well, however it did fail at one stage, which I resolved by individually uploading each album separately.

The main interface looks a lot cleaner. The only initial thing that bothered me was not being able to work out how to upload pictures in bulk! By default, the installation only provided uploading via web browser. This was quickly remedied after I located the plugins facility. A few moments of one-click installation, and the Java Applet I was so fond of in the past was back. I was also pleasantly surprised by the fact that there are now more options for uploading, ranging from WebDAV, Windows XP Publishing etc available.

One good new option was the fact if there are no publicly available albums, a user is prompted to log in with credentials. Previous versions of Gallery presented users with a page with no albums on it, confusing many of them.

I also like the fact that albums now display the total number of photos within them, even when they are within a nested sub-album! Everything is looking good so far!

3 comments:

Marc said...

Have you been upgraded to the "new platform"? I joined startlogic after, so I am on VDeck 3.0 from the start. I am getting a weird error message when trying to install Gallery2:

Warning: session_start() [function.session-start]: open(/var/php_sessions/sess_c522da8c1fc3e809a6642c88b97d1c8c, O_RDWR) failed: No such file or directory (2) in /hermes/bosweb/web289/b2893/xx.xxxx/public_html/gallery/lib/support/GallerySetupUtilities.class on line 348

On the web, it looks like the session variable is set wrong in the php.ini, but it appears that we do not have access to that. Have you seen this?

Hayden Tennent said...

Marc, I am yet to be upgraded to the new platform unfortunately.

I have not seen this error appear in my Gallery.

Regarding the editing of php.ini, Startlogic have posted a link to a PHP editor at:

http://www.startlogic.com/member/cgiManagement/PHPplus.bml

Let me know if this grants you access to editing the php.ini file.

Marc said...

I found a clue here:

http://gallery.menalto.com/node/72180

They said you could put an ini_set call in upgrade. SInce I was not upgrading, I put it in install. Worked like a champ.

in upgrade/index.php, after >?php, add
ini_set('session.save_path', '/home/users/web/b919/ipw.queallyn/public_html/gallery2/somefolder');